[Atualização estável] 05-09-2019 – Kernels, Mesa 19.1.5, XFCE 4.14, KDE, Nvidia 435xx, LibreOffice

Olá comunidade,

Tenho o prazer de anunciar outra atualização estável . Principalmente, temos atualizações do Manjaro 18.1-rc10 , Nvidia e KDE

Atualizar notícias

Esta atualização contém as seguintes alterações:

  • O Manjaro 18.1-rc10 foi lançado. Teste e envie-nos um feedback.
  • A maioria dos nossos Kernels foi atualizada. Observe que o linux50-rt foi descartado e a série RT-Kernel 5.2 adicionada
  • Os drivers da Nvidia foram estendidos para as séries 418xx, 430xx e 435xx
  • Mesa está agora em 19.1.5
  • O OnlyOffice foi adicionado pela comunidade. Saiba mais aqui
  • Palemoon está agora em 28.7.0
  • Atualizações do pacote KDE-dev para refletir as alterações mais recentes feitas pelo KDE Dev-Team.
  • O KDE Frameworks é lançado na versão 5.61
  • Primeira versão do KDE Apps 19.08 series
  • Correções em nossas ferramentas e Calamares
  • cdemu está agora em 3.2.3
  • Atualizações para os drivers Vulkan e AMD Vulkan
  • O Thunderbird está agora na série 68 . Leia o guia de solução de problemas para problemas que você pode ter com suas extensões preferidas
  • Pacotes XFCE foram renovados. Também adicionamos alguns pacotes de meta-transição, que descartam nossas gtk3-builds.
  • O LibreOffice agora está em 6.3.0 e 6.2.6
  • A Nvidia está agora em 435,17. Para obter instruções de descarga da GPU, consulte aqui .
  • Haskell e Firefox foram atualizados para seus últimos lançamentos
  • O VIM recebeu novos pacotes de verificação ortográfica
  • Atualizações para o certbot e nossos clientes do Steam
  • Systemd conseguiu algumas correções para o dbus
  • As atualizações upstream usuais, incluindo python e perl
  • Os esforços mais recentes do KDE podem ser revisados ​​por meio do KDE-Dev ISO atual ou do KDE-Vanilla ISO atual 
  • Os ISOs de Manjaro Juhraya foram atualizados, incluindo o suporte flatpak e snap pré-ativado. O Office pode ser selecionado durante a instalação entre o libreoffice-still ou freeoffice : XFCE , KDE , Gnome

Envie-nos os comentários habituais e informe-nos o que você pensa sobre esta atualização.


Kernels suportados atualmente

  • linux316 3.16.73
  • linux44 4.4.190 (sem módulo nvidia-340 legado!)
  • linux49 4.9.190
  • linux414 4.14.141
  • linux419 4.19.69
  • linux51 5.1.21 [EOL]
  • linux52 5.2.11 (sem módulo catalisador!)
  • linux53 5.3-rc7 (nem todos os módulos foram construídos ainda!)
  • linux419-rt 4.19.50_rt22
  • linux52-rt 5.2.10_rt5-1

Atualizações de pacote (terça-feira, 3 de setembro, 01:21:53 CEST 2019)

  • community estável x86_64: 1720 pacote (s) novo (s) e 1737 pacote (s) removido (s)
  • core estável x86_64: 56 pacote (s) novo (s) e 59 pacote (s) removido (s)
  • extra estável x86_64: 1149 pacote (s) novo (s) e 1168 pacote (s) removido (s)
  • multibib estável x86_64: 42 pacote (s) novo (s) e 39 pacote (s) removido (s)

Uma lista de todas as alterações de pacotes pode ser encontrada aqui .

Problemas e soluções conhecidos

Alterações feitas no Grub 2.04-6

Devido a alguns erros nos patches do Fedora em relação ao BTRFS, estamos usando agora a abordagem do Ubuntu para ocultar o menu GRUB_TIMEOUT.

Estas são as opções atuais para estilizar o tempo limite:

GRUB_TIMEOUT_STYLE=countdown
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT_STYLE=menu

Convém verificar novamente suas configurações em /etc/default/grub

Também fornecemos um novo pacote chamado grub-vanilla . Saiba mais sobre o assunto aqui .


O Thunderbird 68.0 desativou minhas extensões!

O Thunderbird 68 muda a maneira como as extensões funcionam de acordo com o Firefox 68. Isso significa que extensões incompatíveis estão desabilitadas.

Os desenvolvedores do Thunderbird tornaram o mais fácil possível para os desenvolvedores de extensões atualizarem as extensões para fazê-los funcionar novamente.

No entanto, levará tempo para que as extensões 1) sejam atualizadas e 2) cheguem ao AMO para download.

Você tem duas opções básicas:

  1. Adicione IgnorePkg = thunderbirdao seu /etc/pacman.confaté que sua extensão “crítica” seja atualizada
  2. Continue procurando atualizações para sua extensão “crítica” e, possivelmente, incomodar o desenvolvedor para atualizá-la

A opção 2 é a mais proativa.


pip se comporta de maneira diferente

pipagora inclui por padrão o --usersinalizador para todas as operações.

Para reverter para o comportamento “normal”, basta editar ou remover /etc/pip.confpara remover user=yes.

 Chamada para teste: Tornando `pip` padrão como` –user`

Desde tempos imemoriais, pessoas usam o sudo pip install para solucionar problemas de permissões, em vez de simplesmente usar o pip install –user. Há longas discussões de anos para abordar esse upstream, bem como outras abordagens para adicionar um diretório separado para o instalador de módulos com o pip. No entanto, parece haver uma maneira mais fácil de usar o padrão –user. Para testar isso, você precisará de atualizações para dois pacotes, filesystem-2018.9-3 e python-pip-19.2.3-1.0 (ambos atualmente em instável). sistema de arquivos-20…


Caracteres asiáticos/CJK são exibidos como blocos

Instale noto-fonts-cjk ou outra fonte de sua escolha. O problema parece relacionado a uma atualização do ttf-droid.

https://bugs.archlinux.org/task/63205


A atualização libbloom>=1.6-2 requer intervenção manual

(Retirado do site do Arch Linux, 2019-07-11 por Felix Yan. Fonte: https://www.archlinux.org/news/libbloom16-2-update-requires-manual-intervention )

O pacote libbloom anterior à versão 1.6-2 estava ausente no link do soname. Isso foi corrigido no 1.6-2, portanto, a atualização precisará substituir o link do soname não rastreado criado pelo ldconfig. Se você receber um erro

libbloom: /usr/lib/libbloom.so.1 exists in filesystem

ao atualizar, use

pacman -Suy --overwrite usr/lib/libbloom.so.1

para executar a atualização.

A atualização tensorflow>=1.14.0-5 requer intervenção manual

De Konstantin Gizdov em 20 de agosto de 2019

Os pacotes tensorflow anteriores à versão 1.14.0-5 estavam faltando alguns links do soname. Isso foi corrigido em 1.14.0-5, portanto, a atualização precisará substituir os links do soname não rastreados criados pelo ldconfig. Se você receber um erro como esse.

tensorflow: /usr/lib/libtensorflow.so.1 exists in filesystem
tensorflow: /usr/lib/libtensorflow_cc.so.1 exists in filesystem
tensorflow: /usr/lib/libtensorflow_framework.so.1 exists in filesystem

ao atualizar, use

pacman -Suy --overwrite=usr/lib/libtensorflow.so.1,usr/lib/libtensorflow_cc.so.1,usr/lib/libtensorflow_framework.so.1

para executar a atualização.

Esta postagem é apenas uma tradução, o original você encontra aqui.

2 Comentários

  • Thierry Rojas Bobadilha

    Sincronizando banco de dados de pacotes…
    Atualizando manjariando-deps.db…
    Erro: manjariando-deps: a chave “A62F9F0C359C3702338F0937DC35688412042242” é desconhecida
    Erro: a chave “A62F9F0C359C3702338F0937DC35688412042242” não pôde ser procurado remotamente
    Atualizando manjariando.db…
    Erro: manjariando: a chave “A62F9F0C359C3702338F0937DC35688412042242” é desconhecida
    Erro: a chave “A62F9F0C359C3702338F0937DC35688412042242” não pôde ser procurado remotamente
    Atualizando manjariando-themes.db…
    Erro: manjariando-themes: a chave “A62F9F0C359C3702338F0937DC35688412042242” é desconhecida
    Erro: a chave “A62F9F0C359C3702338F0937DC35688412042242” não pôde ser procurado remotamente
    Inicializando atualização completa do sistema…
    Clonando google-chrome arquivos para compilar…
    Verificando 1google-chrome dependências…
    Falha ao preparar transação.
    Edit google-chrome build files

    Inicializando atualização completa do sistema…
    Clonando google-chrome arquivos para compilar…
    Verificando 1google-chrome dependências…
    Falha ao preparar transação.
    Falha ao preparar transação:
    base de dados inválida ou corrompida

    Curtir

    • Nós corrigimos o erro que estava causando isso, sincronize a base de dados pelo terminal para garantir.
      sudo pacman -Sy

      Se mesmo assim você continuar com o problema, nós notifique novamente.

      Saudações.

      Curtir

Deixe um comentário

Faça o login usando um destes métodos para comentar:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google

Você está comentando utilizando sua conta Google. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s

Este site utiliza o Akismet para reduzir spam. Saiba como seus dados em comentários são processados.