Editar pacote da AUR com o Pamac

Muitos usuários ainda não sabe o quanto é fácil editar um pacote da AUR antes da instalação, devemos que existem muitos tutoriais relacionados com isso, mas eles são para as versões antigas do Pamac, ou melhor, quando o Pamac ainda não tinha o suporte integrado nele.

Vamos mostrar o quão simples é editar um PKGBUILD através da interface gráfica (GUI) do Pamac, estaremos utilizando o programa XMind como exemplo, já que o mesmo necessita de edição para funcionar corretamente.

A edição abaixo é somente para quem já possui o jre8-openjdk instalado, se você quer instalar o XMind e possui o jre10-openjdk, não é necessário as alterações, mas desinstale o XMind se ele estiver instalado e apague a pasta oculta .xmind da sua home. Os demais usuários que estará utilizando as informações abaixo só como exemplo, não precisa verificar a versão do jre (há menos que o seu programa também necessite dele).

Exemplo:

Abra o Pamac e pesquise pelo XMind (ou seu programa desejado).

Screenshot_20190922_152507

Clique sobre ele, clique na aba Compilar arquivos, agora pesquise pela linha que contém if [[ “$JAVA_VERSION” != “8” ]]; then (daqui em diante você coloca as informações necessárias para o seu programa).

Screenshot_20190922_152531

Agora você vai comentar as 3 linhas destacadas na imagem abaixo.

Screenshot_20190922_152755

Para comentar, basta colocar o carácter # antes da primeira palavra.

Screenshot_20190922_152853

Agora clique no botão Compilação para marcar a instalação, e clique em Aplicar para instalar (como mostra a imagem acima).

Será solicitado sua senha, e após digitar a senha e clicar em OK, na próxima tela basta clicar em Aplicar.

Pronto, seu PKGBUILD foi editado e seu programa vai instalar da forma correta. Lembre-se que esse tutorial é só um exemplo de como editar a instalação de um programa da AUR.

As vezes pode acontecer de não mostrar os detalhes do download de início, observe se sua conexão está sendo utilizada antes de cancelar o procedimento.

Screenshot_20190922_153300

Lembre-se que os programas vão utilizar a versão do Java especificada no seu bashrc ou zshrc da sua home, se você não especificou nenhuma versão lá, ele vai utilizar a versão mais atual/recente, mas lembre-se que ele não está funcionando com as versões mais atuais do jre (13, 12 e 11).

Para aqueles que precisam utilizar o XMind com o jre8-openjdk, basta seguir o tutorial acima que ele irá funcionar corretamente, sem necessidade de demais intervenções.

As informações contidas acima na correção do XMind, estão nos comentários da AUR desde o mês de Janeiro, então não fique bravo quando alguém lhe passar o link da correção/wiki ao invés de lhe mostrar como se faz, ele só está tentando acostumar você em caminhar com as próprias pernas.


Caso algum programa que você goste ainda não tenha uma versão para Manjaro, por favor, escreva nos comentários o nome do programa que iremos procurar por algum equivalente ou, se possível a portabilidade para Manjaro, entraremos em contato com desenvolvedores.

Por favor, não deixe de compartilhar nas redes sociais as publicações deste blog, pois nosso incentivo para produzir um conteúdo bacana é saber que estamos ajudando pessoas a conhecer cada vez mais as funcionalidades dessa maravilhosa distro Linux.

Nos acompanhe:

Deixe um comentário

Faça o login usando um destes métodos para comentar:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google

Você está comentando utilizando sua conta Google. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s

Este site utiliza o Akismet para reduzir spam. Saiba como seus dados em comentários são processados.