[Atualização estável] 2019-10-10 – Gnome 3.34.1, Plasma 5.16.5, KDE Apps e Framework, Pamac 9.0, Mesa 19.2.1

Olá comunidade,

Tenho o prazer de anunciar outra atualização estável . Demoramos mais de um mês para concluir este pacote de atualização para nossa filial estável . Tivemos um pouco de dificuldade para manter o Gnome 3.34 estável o suficiente, por isso decidimos polir isso antes de fazer outra atualização neste ramo. Também conseguimos obter suporte a Snap na série Pamac 9.0 . Você pode instalar um novo plugin para essa função. Como sempre, também atualizamos o KDE e o Budgie e adicionamos mais atualizações ao XFCE 4.14 . Aproveite as alterações mais recentes nas mídias de instalações 18.1.1-rc2.

Novidades da atualização.

Esta atualização contém as seguintes alterações:

  • Todos os Kernels foram atualizados e reconstruídos com o novo conjunto de ferramentas . Largamos a série Kernel 5.1
  • A partir da série Pamac 9.0, agora suportamos os snaps por meio de um plug-in. Nosso foco foi corrigir os problemas relatados desta série.
  • O Gnome foi atualizado para 3.34.1. Conte-nos suas descobertas!
  • Budgie foi atualizado para trabalhar com o Gnome 3.34
  • Agora temos o KDE Plasma 5.16.5
  • Os aplicativos do KDE estão agora em 19.08.1
  • O KDE Framework agora está em 5.62 e atualizamos a maioria dos nossos pacotes do KDE-git
  • O Mesa foi atualizado para 19.2.1
  • A tão esperada atualização do LibreOffice 6.3.2 foi adicionada.
  • O LibreOffice recebeu as atualizações de segurança necessárias
  • ambiente de codificação Gambas foi atualizado para 3.14.0
  • O Firefox foi corrigido por falhas durante a reprodução de vídeos do Youtube
  • Algum trabalho foi feito sobre Octopi . Dê-nos um feedback se houver algumas melhorias.
  • Atualmente, estamos trabalhando no repo-compare, um novo serviço da web.
  • Kodi está agora em 18,4
  • bauh está agora em 0.6.1
  • Nós trabalhamos em nossos Temas Gnome
  • Calamares ganhou algumas correções em relação ao GeoIP
  • O ZFS foi atualizado para 0.8.2
  • O Gstreamer foi atualizado para 1.16.1
  • Bluez está agora em 5,51
  • Algum navegador foi atualizado conforme necessário
  • O Thunderbird está agora em 68.1.0. Também levamos isso ao nosso ramo estável .
  • Conseguimos renovar nossos pacotes KDE-Dev
  • O Qt5 passou para 5.13.1, o que traz as correções necessárias. Relate se ainda precisamos reconstruir alguns pacotes.
  • As atualizações usuais de haskell , php e python regulares
  • Melhorias regulares adicionais e renovações de pacotes upstream
  • Manjaro 18.1.1-rc2 foi lançado! Teste e envie comentários: gnomekdexfce
  • Os esforços mais recentes do KDE podem ser revisados ​​por meio do KDE-Dev ISO atual ou do KDE-Vanilla ISO atual.

Envie-nos os comentários habituais e informe-nos o que você pensa sobre esta atualização.


Kernels suportados atualmente

  • linux316 3.16.75
  • linux44 4.4.196 (sem módulo nvidia-340 legado!)
  • linux49 4.9.196
  • linux414 4.14.148
  • linux419 4.19.78
  • linux52 5.2.20 [EOL] (sem módulo catalisador!)
  • linux53 5.3.5 (sem módulo catalisador!)
  • linux54 5.4.0-rc2 (nem todos os módulos foram construídos ainda!)
  • linux419-rt 4.19.72_rt25
  • linux52-rt 5.2.19_rt11

O gerenciador de kernel do Manjaro facilita na identificação, instalação e na manutenção.

Atualizações do pacote (qui, 10 de outubro às 13:58:42 CEST 2019)

  • community estável x86_64: 2099 pacote (s) novo (s) e 2058 removido (s)
  • core estável x86_64: 99 pacote (s) novo (s) e 97 removido (s)
  • extra estável x86_64: 1460 pacote (s) novo (s) e 1545 removido (s)
  • multilib estável x86_64: 63 pacote (s) novo (s) e 58 removido (s)

Uma lista detalhada de todas as alterações de pacotes pode ser encontrada aqui.


Problemas e soluções conhecidos.

Substitua linux51 por community/linux-latest?

linux51é EOL e foi removido dos repositórios. Ele será substituído por um metapacote que, a partir de agora, manterá você em um kernel mantido.

Se você quiser manter o antigo kernel e módulos, em seguida, incluí-los em seu pacman.conf‘s IgnorePkg.

pip se comporta de maneira diferente

Com o 19.2.3-1.4pacote, pipagora inclui por padrão o --usersinalizador para todas as operações. Isso ajudará a evitar conflitos de arquivo causados ​​por sudo pip install.

Isso funcionará corretamente em qualquer venvambiente ou em qualquer lugar onde a ensurepipfuncionalidade do Python for usada. Pode quebrar, por exemplo, ambientes Conda.

Para reverter para o comportamento “normal”, basta editar ou remover /etc/pip.confpara remover user=yes.

Chamada para teste: Tornando `pip` padrão como` –user`

Desde tempos imemoriais, as pessoas usam ou instalam o pip para solucionar problemas de permissão, em vez de simplesmente usar o pip install –user. Há longas discussões de anos para abordar esse upstream, bem como outras abordagens para adicionar um diretório separado para o instalador de módulos com o pip. No entanto, parece haver uma maneira mais fácil de usar o padrão – usuário. Para testar isso, você pode atualizar atualizações para dois pacotes, filesystem-2018.9-3 e python-pip-19.2.3-1.2 (ambos atualmente em instável). sistema de arquivos-20…

Pamac-Qt não é compatível com 9.0 API of Pamac

Pamac Qt 0.3 pré-RC: Para o lançamento, precisa de ajuda nos testes

Não é muito óbvio, mas acho que encontrei a fonte. 
Por enquanto, é muito mais importante adotar a lógica do aplicativo na próxima versão 9.0

gnome-shell-extension-desktop-icons

o pkgver 19.10.1 é enviado com um gancho para remover a capacidade do gnome-shell. Uma mensagem está presente durante a instalação, mas essencialmente você precisa reiniciar o sistema para mostrar corretamente os ícones na área de trabalho. Mais informações aqui.


Esta postagem é apenas uma tradução, o original você encontra aqui.

Deixe um comentário

Faça o login usando um destes métodos para comentar:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google

Você está comentando utilizando sua conta Google. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s

Este site utiliza o Akismet para reduzir spam. Saiba como seus dados em comentários são processados.