Manjariando
Manjariando
Compartilhando a simplicidade do Manjaro.
Sep 17, 2021 Sep 17, 2021 5 min de leitura

Atualização Estável 2021 09 16

thumbnail for this post

Mais uma atualização para o ramo stable foi liberada, os gerenciadores de pacotes foram atualizados, assim como o Firefox, Thunderbird, LibreOffice e a Steam. Tirando o kernel RT e o 5,12, todos os demais foram atualizados.

Abaixo nós deixaremos as informações básicas sobre o que foi atualizado, sobre os erros conhecidos (pode ser alterado com o passar do dia), e a forma de como atualizar o sistema (seguindo as informações do fórum).

Se você quiser testar as ISOs de desenvolvimento, você pode baixar a versão Cutefish, Plasma, Gnome e XFCE. Recomendamos o Jdownloader para fazer o download dessas ISOs, pois ele faz todo o trabalho e você não irá se preocupar em juntar as partes dos arquivos.

Principais Updates #
  • A maioria de nossos Kernels foram atualizados
  • Pipewire está agora em 0.3.35
  • Mozilla Software foi atualizado: Firefox 92, Thunderbird 91
  • A versão estável do LibreOffice está agora em 7.1.6
  • Pamac está agora em 10.2.0, que novamente se concentra na área de trabalho primeiro. Para mobile, inicie o pamac-manager com --mobile switch
  • Pacman está agora em 6.0.1
  • O cliente Steam foi renovado para corrigir problemas conhecidos
  • Systemd está agora em 249.4
  • Outras atualizações regulares de upstream
Kernels Suportados pelo Manjaro #
  • linux44 4.4.283
  • linux49 4.9.282
  • linux414 4.14.246
  • linux419 4.19.206
  • linux54 5.4.144
  • linux510 5.10.63
  • linux512 5.12.19 [EOL]
  • linux513 5.13.15
  • linux514 5.14.2
  • linux510-rt 5.10.52_rt47
Problemas conhecidos #

Freetype2

A atualização do Freetype2 pode quebrar aplicativos como o Steam. Para o Steam, você pode mudar para o programa beta.

Chaves

Talvez você possa ter algum problema com relação as chaves do repositório do Manjaro, se isso acontecer, siga os passos abaixo. Mas só faça se você realmente tiver problemas, as mensagens gpg: error reading key: No public key e Error while configuring manjaro-keyring não é sinal que você precise fazer o procedimento.

sudo rm -r /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate manjaro
sudo pacman-key --populate archlinux
Se você utilizar o nosso repositório, clique aqui
sudo pacman -Syvv manjaro-keyring

É recomendado remover as assinaturas dos pacotes com falha em /var/cache/pacman/pkg/ e obter os substituídos do Build-Server:

sudo rm -v /var/cache/pacman/pkg/*.sig
sudo pacman -Syvv

libcanberra

Problemas que você pode encontrar se instalou o Manjaro com uma ISO muito antiga ou faz tempo que não atualiza o sistema (nenhuma das duas opções são recomendada).

Leia mais...

Compiz

Pacotes Compiz como compiz-easy-patch foram retirados de nossos repositórios. Devido à atualização do protobuf, você pode precisar reconstruir esse pacote localmente no seu final. Compiz-easy-patch removido dos repositórios.

Signal Desktop

signal-desktop-beta não quer construir e falha com um erro

Leia mais...

obmenu-generator

O tratamento de ícones no obmenu-generator está quebrado.

Leia mais...
Atualizando o sistema #

Antes de utilizar o Pamac na sua forma gráfica ou pelo terminal, o correto a se fazer é classificar os espelhos e só depois atualizar o sistema, você pode conferir o nosso artigo explicando como se fazer isso.

Após classificar os espelhos, você pode atualizar o seu sistema através da interface gráfica do Pamac, mas recomendamos a utilização do terminal. Outra recomendação nossa é, atualize primeiro somente os pacotes dos repositório (se você utiliza o repositório do blog, lembre-se de aguardar ao menos 24 horas), e só depois atualize os pacotes provenientes da AUR.

Comando para atualizar somente os pacotes presentes em repositórios, os pacotes da AUR não serão atualizados.

pamac update --force-refresh --no-aur

Seguindo as informações acima, provavelmente você não terá maiores problemas. Verifique as informações do progresso da atualização, muitos usuários atualizam o sistema e não olham se existem mensagens de erros.

Problemas com pacotes da AUR #

Após uma atualização do Manjaro, é comum que alguns pacotes instalados da AUR parem de funcionar. Normalmente isso acontece com pacote realmente compilados (aqueles que demoram mais tempo e fica passando muitas letrinhas sobre o que está sendo feito), e para corrigir, você precisará recompilar o pacote do próprio programa ou de alguma dependência que ele precise (que também foi instalada da AUR).

Nós fazemos esse processo de re-compilar nos pacotes do nosso repositório, e por isso que recomendamos que o usuário aguarde ao menos 24 horas. Assim ele atualizará o sistema e os pacotes que disponibilizamos e não encontrará problemas, se for ansioso, atualizará o sistema antes e terá problemas com os pacotes do nosso repositório, mas isso será por causa da ansiedade dele, já que as nossas atualizações provavelmente ainda não estavam disponíveis.

Ainda não consigo atualizar #

Se você seguiu as informações e ainda não consegue atualizar o sistema, tenha certeza que verificou as informações dos problemas antigos. Você pode entrar em nosso grupo no telegram para que possamos lhe ajudar com o problema, mas verifique se as informações não estão listadas nos problemas antigos.


Caso algum programa que você goste ainda não tenha uma versão para Manjaro, por favor, escreva nos comentários o nome do programa que iremos procurar por algum equivalente ou, se possível a portabilidade para Manjaro, entraremos em contato com desenvolvedores.

Por favor, não deixe de compartilhar nas redes sociais as publicações deste blog, pois nosso incentivo para produzir um conteúdo bacana é saber que estamos ajudando pessoas a conhecer cada vez mais as funcionalidades dessa maravilhosa distro Linux.

Acompanhe o blog

comments powered by Disqus